Node.js Bundled Brotli Decoder Flaw Allowed Out-of-Bounds Write (CVE-2026-111497)

A memory-corruption flaw was found in the Brotli decoder that Node.js bundles inside its node:zlib module. An invalid block switch was mistakenly treated as a temporary need for more input, letting streaming continue into an eight-byte buffer and write beyond its end. The vulnerability, tracked as CVE-2026-111497 and scored 9.2 under CVSS 4.0, could be triggered by crafted Brotli data from an unauthenticated remote attacker. Affected Node.js lines are 26.x, 24.x and 22.x, and fixed builds 26.12.1, 24.22.1 and 22.23.4 were released in the October 2026 security update, which also included dependency updates. The underlying Google Brotli versions 1.0.3 through 1.2.0 are affected, with fixes in 1.0.10, 1.1.1 and 1.2.1.
This is an AI-generated summary. ShortSingh links to the original source for the complete article.

Discussion (0)
Log in to join the discussion and vote.
Log in